amiga.org
     
iconAll times are GMT -6. The time now is 05:49 PM. | Welcome to Forum, please register to access all of our features.

Amiga.org Amiga computer related discussion Amiga Software Issues and Discussion OWB/Origyn Browser Problem, please help :(

Amiga Software Issues and Discussion This forum exists for the discussion of the use, issues with, and fun brought about by classic and next generation Amiga software.

Reply
 
Thread Tools Display Modes
Old 05-06-2009, 04:22 AM   #1
Fingers
Technoid
Points: 5,895, Level: 49 Points: 5,895, Level: 49 Points: 5,895, Level: 49
Activity: 12% Activity: 12% Activity: 12%
 
Join Date: Apr 2008
Location: Belco, Australia
Posts: 327
Default OWB/Origyn Browser Problem, please help :(

In MorphOS I'm having problems.

It would seem something is out of date.

The manual says this: "You can either update "curl-ca-bundle.crt" file,
or ignore SSL errors with: "setenv WEBKIT_IGNORE_SSL_ERRORS 1"".

Problem is I don't know where to get the updated curl-ca-bundle.crt file.

I also don't know how to do the "setenv" thing.

Please help me, I can't even check my email becuase the Hotmail certificate that this relates to has changed :-(

PZ.
Fingers is offline   Reply With Quote
Old 05-06-2009, 04:34 AM   #2
Piru
Banned
Points: 30,457, Level: 100 Points: 30,457, Level: 100 Points: 30,457, Level: 100
Activity: 69% Activity: 69% Activity: 69%
 
Join Date: Aug 2002
Location: Helsinki, Finland
Posts: 6,946
Default Re: OWB/Origyn Browser Problem, please help :(

Tried
Code:
setenv WEBKIT_IGNORE_SSL_ERRORS 1
?
Piru is offline   Reply With Quote
Old 05-06-2009, 04:36 AM   #3
Fingers
Technoid
Points: 5,895, Level: 49 Points: 5,895, Level: 49 Points: 5,895, Level: 49
Activity: 12% Activity: 12% Activity: 12%
 
Join Date: Apr 2008
Location: Belco, Australia
Posts: 327
Default Re: OWB/Origyn Browser Problem, please help :(

Quote:
Piru wrote:
Tried
Code:
setenv WEBKIT_IGNORE_SSL_ERRORS 1
?
Hi Piru,

I'd love to try that, but I have no idea where to put that command.

Please understand, I know nothing about software.

Thanks for any help

PZ.
Fingers is offline   Reply With Quote
Old 05-06-2009, 04:43 AM   #4
Piru
Banned
Points: 30,457, Level: 100 Points: 30,457, Level: 100 Points: 30,457, Level: 100
Activity: 69% Activity: 69% Activity: 69%
 
Join Date: Aug 2002
Location: Helsinki, Finland
Posts: 6,946
Default Re: OWB/Origyn Browser Problem, please help :(

Quote:
I'd love to try that, but I have no idea where to put that command.
shell.

After that start OWB.

If you want to have it permanently enabled you can also save it with:
Code:
setenv save WEBKIT_IGNORE_SSL_ERRORS 1
Piru is offline   Reply With Quote
Old 05-06-2009, 04:44 AM   #5
Golem!dk
Technoid
Points: 6,795, Level: 54 Points: 6,795, Level: 54 Points: 6,795, Level: 54
Activity: 14% Activity: 14% Activity: 14%
 
Golem!dk's Avatar
 
Join Date: Dec 2002
Posts: 414
Default Re: OWB/Origyn Browser Problem, please help :(

Googling curl-ca-bundle.crt gives some hints, you may have to rename cacert.pem to curl-ca-bundle.crt if you grab the automated conversion. The setenv "thing" is a command you can enter in a shell window.
Golem!dk is offline   Reply With Quote
Old 05-06-2009, 05:04 AM   #6
Fingers
Technoid
Points: 5,895, Level: 49 Points: 5,895, Level: 49 Points: 5,895, Level: 49
Activity: 12% Activity: 12% Activity: 12%
 
Join Date: Apr 2008
Location: Belco, Australia
Posts: 327
Default Re: OWB/Origyn Browser Problem, please help :(

Quote:
Piru wrote:
shell.

After that start OWB.

If you want to have it permanently enabled you can also save it with:
Code:
setenv save WEBKIT_IGNORE_SSL_ERRORS 1
Working great now, thanks Piru! :-D

PZ.
Fingers is offline   Reply With Quote
Old 05-06-2009, 05:44 AM   #7
Fingers
Technoid
Points: 5,895, Level: 49 Points: 5,895, Level: 49 Points: 5,895, Level: 49
Activity: 12% Activity: 12% Activity: 12%
 
Join Date: Apr 2008
Location: Belco, Australia
Posts: 327
Default Re: OWB/Origyn Browser Problem, please help :(

Oh & thanks to you too Golem :-D

I'm happy just to use the ignore ssl errors command (saved), as a permanent solution is better for me than something that needs to be manually updated all the time.

My kid doesn't use MorphOS, only me & I only go to sites I trust with it anyway.

PZ.
Fingers is offline   Reply With Quote
Old 05-06-2009, 06:20 AM   #8
Fingers
Technoid
Points: 5,895, Level: 49 Points: 5,895, Level: 49 Points: 5,895, Level: 49
Activity: 12% Activity: 12% Activity: 12%
 
Join Date: Apr 2008
Location: Belco, Australia
Posts: 327
Default Re: OWB/Origyn Browser Problem, please help :(

On a side note, I tried OWB v1.2 & every time I ran it the font initialization ran...as if it was the first time I opened OWB...but every single time.

Back on v1.1 & with help from above everything is ok, BUT, why would V1.2 do what I described?

MorphOS 2.2 on Efika if that's of any help. I don't really NEED V1.2 of OWB, just wondering why it kept stuffing up like that. Removed & re-installed a number of times, but it kept happening. Oh & I was using the Lite version.

Happy where I am now, just wondering... :-?

PZ.
Fingers is offline   Reply With Quote
Old 05-06-2009, 08:39 AM   #9
Fab12
Beginner
Points: 2,055, Level: 27 Points: 2,055, Level: 27 Points: 2,055, Level: 27
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2006
Posts: 37
Default Re: OWB/Origyn Browser Problem, please help :(

Unless you have a write protected filesystem which would prevent the cache file creation, there's no reason it would recreate it each time (besides, it hasn't changed since 1.1 in that regard).
Fab12 is offline   Reply With Quote
Old 05-06-2009, 05:44 PM   #10
Fingers
Technoid
Points: 5,895, Level: 49 Points: 5,895, Level: 49 Points: 5,895, Level: 49
Activity: 12% Activity: 12% Activity: 12%
 
Join Date: Apr 2008
Location: Belco, Australia
Posts: 327
Default Re: OWB/Origyn Browser Problem, please help :(

Thanks Fab,

This MorphOS install is from a previous backup...maybe something happened along the way.

PZ.
Fingers is offline   Reply With Quote
Reply

Bookmarks

Tags
owb or origyn , browser , problem

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Origyn Web Browser V1.4 Tumbleweed Amiga Software Issues and Discussion 2 01-31-2009 06:29 AM
Origyn Web Browser (68k) - Help DBAlex Amiga Software Issues and Discussion 7 04-30-2008 04:12 PM
What web browser do you use, and why ? EdKing Amiga Software Issues and Discussion 18 09-04-2004 02:04 PM
OS4 Web Browser and more? bon Amiga Software Issues and Discussion 23 10-15-2003 12:56 AM
Which web Browser? Amiga Software Issues and Discussion 9 01-04-2003 08:05 AM