amiga.org
     
iconAll times are GMT -6. The time now is 03:23 PM. | Welcome to Forum, please register to access all of our features.

Amiga.org Amiga computer related discussion Amiga Hardware Issues and discussion My 500+ Project

Amiga Hardware Issues and discussion This forum is dedicated to the discussion and resolution of issues related to Classic and Next Generation Amiga hardware. Got a problem with a piece of hardware? Click to speak.

Reply
 
Thread Tools Display Modes
Old 06-20-2012, 06:28 PM   #41
AmmoJammo
Cult Member
Points: 4,653, Level: 43 Points: 4,653, Level: 43 Points: 4,653, Level: 43
Activity: 25% Activity: 25% Activity: 25%
 
AmmoJammo's Avatar
 
Join Date: May 2012
Location: Adelaide, Australia
Posts: 610
Default Re: My 500+ Project

Quote:
Originally Posted by djos View Post
Btw when looking at the pics can your trained eye see any pcb damage I need to repair?
its too hard to tell in the pics.

a lot of the tracks look discoloured, it could just be the coating on the board, or it could be the track under the coating...
AmmoJammo is offline   Reply With Quote
Old 06-20-2012, 09:42 PM   #42
MelbourneBen
Technoid
Points: 4,453, Level: 42 Points: 4,453, Level: 42 Points: 4,453, Level: 42
Activity: 5% Activity: 5% Activity: 5%
 
MelbourneBen's Avatar
 
Join Date: May 2009
Location: Adelaide, Australia
Posts: 220
Default Re: My 500+ Project

Quote:
Originally Posted by djos View Post
LOL, very nice - I mainly got the 68010 so that I can switch back to workbench from WHDLoad installed games.

Im going to order the latest Gen 68kIDE adaptor with CF module, 8MB Processor Ram module and 1MB Chip Ram board as soon as I've resurrected my 500+ - that'll give me 10MB Ram total and a 4GB CF HDD.
Hi Mate, where are you going to order the 68kIDE adaptor from? As these still available new? Or are you hoping to get one second hand?
__________________
Member of the Adelaide Commodore & Amiga user group

C= A1200 1D4 4MB Fast Ram FPU, 3.1 roms, 4GB CF HD, PCMCIA NIC, C= 1084s.
MelbourneBen is offline   Reply With Quote
Old 06-20-2012, 10:15 PM   #43
djos
Cult Member
Points: 5,394, Level: 47 Points: 5,394, Level: 47 Points: 5,394, Level: 47
Activity: 2% Activity: 2% Activity: 2%
 
djos's Avatar
 
Join Date: Jun 2012
Location: Melbourne, Australia
Posts: 928
Default Re: My 500+ Project

Quote:
Originally Posted by MelbourneBen View Post
Hi Mate, where are you going to order the 68kIDE adaptor from? As these still available new? Or are you hoping to get one second hand?
MKL (aka mika) on amibay makes and sells the very latest version for about 50 Euros.
__________________
Amiga 1200 w/ KS1.3, ACA1220 16Mhz 128MB w/ RTC, 4GB CF-HDD, a1011 External FDD
Amiga 500 w/ KS1.3, 512k Chip-Ram, 512k Slow-Ram, 4MB Fast-Ram, FDD Boot Selector, HxC RevC SD Floppy Drive, a1010 External FDD
Commodore 64 w/ 1541 Ultimate-II inc Tape Adapter, JiffyDOS, 1541 Disk Drive, 1531 Datasette, C64 Flyer Net Modem, ZoomFloppy
djos is offline   Reply With Quote
Old 06-21-2012, 06:14 PM   #44
djos
Cult Member
Points: 5,394, Level: 47 Points: 5,394, Level: 47 Points: 5,394, Level: 47
Activity: 2% Activity: 2% Activity: 2%
 
djos's Avatar
 
Join Date: Jun 2012
Location: Melbourne, Australia
Posts: 928
Default Re: My 500+ Project

So I took another crack at reviving my 500+ board last night:

I replaced the faulty trace with a direct wire connection:
http://dl.dropbox.com/u/71121999/Ami...PM%20(HDR).jpg

I also tinned the feet of the Gary chip and tested a bunch of traces around the battery area with my multi-meter to ensure they weren't broken (none were) and then fired up my 500+.....

and got this: http://dl.dropbox.com/u/71121999/Ami...%2052%20PM.mov



It doesnt even attempt to boot from a floppy either so Im calling this mobo BUSTED! Oh well, it's been fun trying to repair it as I havent done any board level repair work sine about 1998!! gave me a good excuse to buy a new soldering iron too.

Anyway, all is not lost, I ordered a tested and working Rev6a Mobo from germany and will swap all the ECS chips onto it and upgrade the on board ram to 1MB using the chips from my Rev8a so it''l pretty much be a 500+ regradless.
__________________
Amiga 1200 w/ KS1.3, ACA1220 16Mhz 128MB w/ RTC, 4GB CF-HDD, a1011 External FDD
Amiga 500 w/ KS1.3, 512k Chip-Ram, 512k Slow-Ram, 4MB Fast-Ram, FDD Boot Selector, HxC RevC SD Floppy Drive, a1010 External FDD
Commodore 64 w/ 1541 Ultimate-II inc Tape Adapter, JiffyDOS, 1541 Disk Drive, 1531 Datasette, C64 Flyer Net Modem, ZoomFloppy
djos is offline   Reply With Quote
Old 06-21-2012, 06:25 PM   #45
AmmoJammo
Cult Member
Points: 4,653, Level: 43 Points: 4,653, Level: 43 Points: 4,653, Level: 43
Activity: 25% Activity: 25% Activity: 25%
 
AmmoJammo's Avatar
 
Join Date: May 2012
Location: Adelaide, Australia
Posts: 610
Default Re: My 500+ Project

you made an 8 second video thats 20 megs?!?!
AmmoJammo is offline   Reply With Quote
Old 06-21-2012, 06:32 PM   #46
djos
Cult Member
Points: 5,394, Level: 47 Points: 5,394, Level: 47 Points: 5,394, Level: 47
Activity: 2% Activity: 2% Activity: 2%
 
djos's Avatar
 
Join Date: Jun 2012
Location: Melbourne, Australia
Posts: 928
Default Re: My 500+ Project

Quote:
Originally Posted by AmmoJammo View Post
you made an 8 second video thats 20 megs?!?!
a 720p iPhone video will do that!
__________________
Amiga 1200 w/ KS1.3, ACA1220 16Mhz 128MB w/ RTC, 4GB CF-HDD, a1011 External FDD
Amiga 500 w/ KS1.3, 512k Chip-Ram, 512k Slow-Ram, 4MB Fast-Ram, FDD Boot Selector, HxC RevC SD Floppy Drive, a1010 External FDD
Commodore 64 w/ 1541 Ultimate-II inc Tape Adapter, JiffyDOS, 1541 Disk Drive, 1531 Datasette, C64 Flyer Net Modem, ZoomFloppy
djos is offline   Reply With Quote
Old 06-21-2012, 06:33 PM   #47
Azryl
Technoid
Points: 8,338, Level: 61 Points: 8,338, Level: 61 Points: 8,338, Level: 61
Activity: 6% Activity: 6% Activity: 6%
 
Join Date: Jul 2004
Posts: 386
Default Re: My 500+ Project

LOL.. yeah that was a monster video

okies, I would swap the CIA chips... and see if that gets any further into the boot process

from the cycling power light I would say Gary is faulty, a probable memory or bus conflict.

Before saying the mobo is dead, you really should swap other chips (other than agnus) and see if the board will boot, or gives the customary colours on boot. Better able to see the fault with the colour.

Az
__________________
Completely useless? I can always be used as a bad example
Azryl is offline   Reply With Quote
Old 06-21-2012, 07:05 PM   #48
djos
Cult Member
Points: 5,394, Level: 47 Points: 5,394, Level: 47 Points: 5,394, Level: 47
Activity: 2% Activity: 2% Activity: 2%
 
djos's Avatar
 
Join Date: Jun 2012
Location: Melbourne, Australia
Posts: 928
Default Re: My 500+ Project

Quote:
Originally Posted by Azryl View Post
LOL.. yeah that was a monster video

okies, I would swap the CIA chips... and see if that gets any further into the boot process

from the cycling power light I would say Gary is faulty, a probable memory or bus conflict.

Before saying the mobo is dead, you really should swap other chips (other than agnus) and see if the board will boot, or gives the customary colours on boot. Better able to see the fault with the colour.

Az
Ok I'll swap the CIA chips and see what happens - at least the new mobo will give me a working Gary chip to test as well.

I also hooked up my miggy to my GBS-8220 via MiggyRGB-VGA adapter to GBS-8220 and I got a very distorted green screen that had rolling and tearing and the GBS-8220 couldnt lock onto it.
__________________
Amiga 1200 w/ KS1.3, ACA1220 16Mhz 128MB w/ RTC, 4GB CF-HDD, a1011 External FDD
Amiga 500 w/ KS1.3, 512k Chip-Ram, 512k Slow-Ram, 4MB Fast-Ram, FDD Boot Selector, HxC RevC SD Floppy Drive, a1010 External FDD
Commodore 64 w/ 1541 Ultimate-II inc Tape Adapter, JiffyDOS, 1541 Disk Drive, 1531 Datasette, C64 Flyer Net Modem, ZoomFloppy
djos is offline   Reply With Quote
Old 06-21-2012, 08:04 PM   #49
Lurch
Lifetime Member
Points: 15,615, Level: 80 Points: 15,615, Level: 80 Points: 15,615, Level: 80
Activity: 38% Activity: 38% Activity: 38%
 
Lurch's Avatar
 
Join Date: Dec 2003
Location: Auckland, New Zealand
Posts: 1,419
Send a message via MSN to Lurch
Default Re: My 500+ Project

@djos So you sourced a new a500+ board?
__________________
-=[LurcH]=-
A1200T 060@80MHz | A500 Plus 030@25MHz | Pegasos II G4@1GHz
Lurch is offline   Reply With Quote
Old 06-21-2012, 08:27 PM   #50
djos
Cult Member
Points: 5,394, Level: 47 Points: 5,394, Level: 47 Points: 5,394, Level: 47
Activity: 2% Activity: 2% Activity: 2%
 
djos's Avatar
 
Join Date: Jun 2012
Location: Melbourne, Australia
Posts: 928
Default Re: My 500+ Project

Quote:
Originally Posted by Lurch View Post
@djos So you sourced a new a500+ board?
Not a Rev8a board, it's a Rev6a but I believe it can handle the ECS chipset without any mods and can take an extra 512k ram on-board basically making it a 500+ minus the battery backed RTC.

EDIT: my fatter Agnus may not work in the rev6a board tho but im happy if I get at least 1mb chip ram + 8mb CPU ram from tomthul.
__________________
Amiga 1200 w/ KS1.3, ACA1220 16Mhz 128MB w/ RTC, 4GB CF-HDD, a1011 External FDD
Amiga 500 w/ KS1.3, 512k Chip-Ram, 512k Slow-Ram, 4MB Fast-Ram, FDD Boot Selector, HxC RevC SD Floppy Drive, a1010 External FDD
Commodore 64 w/ 1541 Ultimate-II inc Tape Adapter, JiffyDOS, 1541 Disk Drive, 1531 Datasette, C64 Flyer Net Modem, ZoomFloppy

Last edited by djos; 06-21-2012 at 09:08 PM..
djos is offline   Reply With Quote
Old 06-21-2012, 09:12 PM   #51
Cammy
Defender of the Faith
Points: 12,227, Level: 72 Points: 12,227, Level: 72 Points: 12,227, Level: 72
Activity: 2% Activity: 2% Activity: 2%
 
Cammy's Avatar
 
Join Date: Aug 2007
Location: In my own little world, Australia
Posts: 1,361
Send a message via MSN to Cammy
Default Re: My 500+ Project

It's a shame you couldn't get the A500+ boardworking, would you consider sending it to AmigaManiac for repairs? He's in NSW and can repair most Amiga problems. I just think it's a shame that such a good motherboard would go to waste, I have a busted one here which I'm going to send to him too.
__________________
A1200 030@28Mhz/2MB+32MB/RTC/KS3.1/IDE-CF+4GB/4-Way Clockport Expander/IndivisionAGA/PCMCIA NIC
A1200 020@14Mhz/2MB+8MB/FPU/RTC/KS3.0/IDE-CF+2GB/S-Video
CD32 020@14Mhz/2MB+8MB/RTC/KS3.1/IDE-CF+4GB
A600 030@30Mhz/2MB+64MB/RTC/IDE-CF+4GB/Subway USB/S-Video/PCMCIA NIC/USB Numeric Keypad+Hub+Mouse+Control Pad
A500 000@7Mhz/512kB+512kB/ROM Switcher/KS3.1+1.3/S-Video

Get AmigaOS for your PC, it's FREE and comes in two flavours!
www.icarosdesktop.org
www.aros-broadway.de
Cammy is offline   Reply With Quote
Old 06-21-2012, 09:21 PM   #52
djos
Cult Member
Points: 5,394, Level: 47 Points: 5,394, Level: 47 Points: 5,394, Level: 47
Activity: 2% Activity: 2% Activity: 2%
 
djos's Avatar
 
Join Date: Jun 2012
Location: Melbourne, Australia
Posts: 928
Default Re: My 500+ Project

Quote:
Originally Posted by Cammy View Post
It's a shame you couldn't get the A500+ boardworking, would you consider sending it to AmigaManiac for repairs? He's in NSW and can repair most Amiga problems. I just think it's a shame that such a good motherboard would go to waste, I have a busted one here which I'm going to send to him too.
Im not aware of him? how much does he charge?
__________________
Amiga 1200 w/ KS1.3, ACA1220 16Mhz 128MB w/ RTC, 4GB CF-HDD, a1011 External FDD
Amiga 500 w/ KS1.3, 512k Chip-Ram, 512k Slow-Ram, 4MB Fast-Ram, FDD Boot Selector, HxC RevC SD Floppy Drive, a1010 External FDD
Commodore 64 w/ 1541 Ultimate-II inc Tape Adapter, JiffyDOS, 1541 Disk Drive, 1531 Datasette, C64 Flyer Net Modem, ZoomFloppy
djos is offline   Reply With Quote
Old 06-21-2012, 10:02 PM   #53
MelbourneBen
Technoid
Points: 4,453, Level: 42 Points: 4,453, Level: 42 Points: 4,453, Level: 42
Activity: 5% Activity: 5% Activity: 5%
 
MelbourneBen's Avatar
 
Join Date: May 2009
Location: Adelaide, Australia
Posts: 220
Default Re: My 500+ Project

Quote:
Originally Posted by djos View Post
Im not aware of him? how much does he charge?
Amiga Maniac has a web site here: http://www.amigamaniac.com/

I've bought a few items from him over the last couple of years, always been pretty good service, he's based in NSW.

He sells rom chips at a good price aswell.
__________________
Member of the Adelaide Commodore & Amiga user group

C= A1200 1D4 4MB Fast Ram FPU, 3.1 roms, 4GB CF HD, PCMCIA NIC, C= 1084s.
MelbourneBen is offline   Reply With Quote
Old 06-22-2012, 12:19 AM   #54
Lurch
Lifetime Member
Points: 15,615, Level: 80 Points: 15,615, Level: 80 Points: 15,615, Level: 80
Activity: 38% Activity: 38% Activity: 38%
 
Lurch's Avatar
 
Join Date: Dec 2003
Location: Auckland, New Zealand
Posts: 1,419
Send a message via MSN to Lurch
Default Re: My 500+ Project

Quote:
Originally Posted by Cammy View Post
It's a shame you couldn't get the A500+ boardworking, would you consider sending it to AmigaManiac for repairs? He's in NSW and can repair most Amiga problems. I just think it's a shame that such a good motherboard would go to waste, I have a busted one here which I'm going to send to him too.
Wow thanks Cammy, I also have an A500+ in need of some love. Forgot all about Amiga Maniac, although haven't heard from him in awhile.

Sent him an email about some other stuff but no reply. Might try emailing him again :-)
__________________
-=[LurcH]=-
A1200T 060@80MHz | A500 Plus 030@25MHz | Pegasos II G4@1GHz
Lurch is offline   Reply With Quote
Old 06-22-2012, 12:23 AM   #55
djos
Cult Member
Points: 5,394, Level: 47 Points: 5,394, Level: 47 Points: 5,394, Level: 47
Activity: 2% Activity: 2% Activity: 2%
 
djos's Avatar
 
Join Date: Jun 2012
Location: Melbourne, Australia
Posts: 928
Default Re: My 500+ Project

Quote:
Originally Posted by MelbourneBen View Post
Amiga Maniac has a web site here: http://www.amigamaniac.com/

I've bought a few items from him over the last couple of years, always been pretty good service, he's based in NSW.

He sells rom chips at a good price aswell.
Cheers, I sent him an email.
__________________
Amiga 1200 w/ KS1.3, ACA1220 16Mhz 128MB w/ RTC, 4GB CF-HDD, a1011 External FDD
Amiga 500 w/ KS1.3, 512k Chip-Ram, 512k Slow-Ram, 4MB Fast-Ram, FDD Boot Selector, HxC RevC SD Floppy Drive, a1010 External FDD
Commodore 64 w/ 1541 Ultimate-II inc Tape Adapter, JiffyDOS, 1541 Disk Drive, 1531 Datasette, C64 Flyer Net Modem, ZoomFloppy
djos is offline   Reply With Quote
Old 06-22-2012, 12:26 AM   #56
Lurch
Lifetime Member
Points: 15,615, Level: 80 Points: 15,615, Level: 80 Points: 15,615, Level: 80
Activity: 38% Activity: 38% Activity: 38%
 
Lurch's Avatar
 
Join Date: Dec 2003
Location: Auckland, New Zealand
Posts: 1,419
Send a message via MSN to Lurch
Default Re: My 500+ Project

Quote:
Originally Posted by djos View Post
Cheers, I sent him an email.

Great guy and makes some good hardware :-) Have a couple of his creations.
__________________
-=[LurcH]=-
A1200T 060@80MHz | A500 Plus 030@25MHz | Pegasos II G4@1GHz
Lurch is offline   Reply With Quote
Old 06-22-2012, 03:54 AM   #57
MelbourneBen
Technoid
Points: 4,453, Level: 42 Points: 4,453, Level: 42 Points: 4,453, Level: 42
Activity: 5% Activity: 5% Activity: 5%
 
MelbourneBen's Avatar
 
Join Date: May 2009
Location: Adelaide, Australia
Posts: 220
Default Re: My 500+ Project

Quote:
Originally Posted by Lurch View Post
Wow thanks Cammy, I also have an A500+ in need of some love. Forgot all about Amiga Maniac, although haven't heard from him in awhile.

Sent him an email about some other stuff but no reply. Might try emailing him again :-)
I bought a DB23 connector from him a couple of weeks ago and kickstart roms a few months ago so he`s definately still around. He does sometimes take a little while to reply but I think he runs it as a hobby rather than a business.
__________________
Member of the Adelaide Commodore & Amiga user group

C= A1200 1D4 4MB Fast Ram FPU, 3.1 roms, 4GB CF HD, PCMCIA NIC, C= 1084s.
MelbourneBen is offline   Reply With Quote
Old 06-22-2012, 03:59 AM   #58
djos
Cult Member
Points: 5,394, Level: 47 Points: 5,394, Level: 47 Points: 5,394, Level: 47
Activity: 2% Activity: 2% Activity: 2%
 
djos's Avatar
 
Join Date: Jun 2012
Location: Melbourne, Australia
Posts: 928
Default Re: My 500+ Project

Well I finally got around to finishing making my DB23-GBS Cable and I also swapped around the two CIA chips to no avail - on a positive note my flashing screen is in colour (green)!

http://dl.dropbox.com/u/71121999/Ami...2019.21.41.jpg

PS, the power light blinks 2 times by my count so I need to look that up.

PSS, I dont drink Carlton Mid, that is actually a Coopers Clear (wife has me on a diet from my normal Pale Ale, all for 20 bloody calories!)!
__________________
Amiga 1200 w/ KS1.3, ACA1220 16Mhz 128MB w/ RTC, 4GB CF-HDD, a1011 External FDD
Amiga 500 w/ KS1.3, 512k Chip-Ram, 512k Slow-Ram, 4MB Fast-Ram, FDD Boot Selector, HxC RevC SD Floppy Drive, a1010 External FDD
Commodore 64 w/ 1541 Ultimate-II inc Tape Adapter, JiffyDOS, 1541 Disk Drive, 1531 Datasette, C64 Flyer Net Modem, ZoomFloppy

Last edited by djos; 06-22-2012 at 04:33 AM..
djos is offline   Reply With Quote
Old 06-22-2012, 04:33 AM   #59
djos
Cult Member
Points: 5,394, Level: 47 Points: 5,394, Level: 47 Points: 5,394, Level: 47
Activity: 2% Activity: 2% Activity: 2%
 
djos's Avatar
 
Join Date: Jun 2012
Location: Melbourne, Australia
Posts: 928
Default Re: My 500+ Project

Ok found some doco here: http://en.wikipedia.org/wiki/Power-o...est#Amiga_POST

Tells me bad Chip-ram or Agnus Chip (i'd reseat it but lack a PLCC extraction tool) - I'd be inclined to think the traces from Gary to the chip ram are damaged based on this.

Looks like my Rev6a is gonna get a 512kb chip ram and a Super Denise upgrade when it arrives (will have to look out for an 8372B Fatter Angus so I can got to 2MB chip ram later on).
__________________
Amiga 1200 w/ KS1.3, ACA1220 16Mhz 128MB w/ RTC, 4GB CF-HDD, a1011 External FDD
Amiga 500 w/ KS1.3, 512k Chip-Ram, 512k Slow-Ram, 4MB Fast-Ram, FDD Boot Selector, HxC RevC SD Floppy Drive, a1010 External FDD
Commodore 64 w/ 1541 Ultimate-II inc Tape Adapter, JiffyDOS, 1541 Disk Drive, 1531 Datasette, C64 Flyer Net Modem, ZoomFloppy

Last edited by djos; 06-22-2012 at 04:37 AM..
djos is offline   Reply With Quote
Old 06-22-2012, 10:03 AM   #60
Cammy
Defender of the Faith
Points: 12,227, Level: 72 Points: 12,227, Level: 72 Points: 12,227, Level: 72
Activity: 2% Activity: 2% Activity: 2%
 
Cammy's Avatar
 
Join Date: Aug 2007
Location: In my own little world, Australia
Posts: 1,361
Send a message via MSN to Cammy
Default Re: My 500+ Project

The busted A500+ here also has a flashing green screen and the blinking power LED. The battery damage on this board didn't look too bad, so I hope it can be fixed. Sorry I can't help, but good luck!
__________________
A1200 030@28Mhz/2MB+32MB/RTC/KS3.1/IDE-CF+4GB/4-Way Clockport Expander/IndivisionAGA/PCMCIA NIC
A1200 020@14Mhz/2MB+8MB/FPU/RTC/KS3.0/IDE-CF+2GB/S-Video
CD32 020@14Mhz/2MB+8MB/RTC/KS3.1/IDE-CF+4GB
A600 030@30Mhz/2MB+64MB/RTC/IDE-CF+4GB/Subway USB/S-Video/PCMCIA NIC/USB Numeric Keypad+Hub+Mouse+Control Pad
A500 000@7Mhz/512kB+512kB/ROM Switcher/KS3.1+1.3/S-Video

Get AmigaOS for your PC, it's FREE and comes in two flavours!
www.icarosdesktop.org
www.aros-broadway.de
Cammy is offline   Reply With Quote
Reply

Bookmarks

Tags
500 , project

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump