amiga.org
     
iconAll times are GMT -6. The time now is 06:43 PM. | Welcome to Forum, please register to access all of our features.

Amiga.org Amiga computer related discussion Amiga Hardware Issues and discussion Upgraded BPPC 040 to 060. Just one minor issue...

Amiga Hardware Issues and discussion This forum is dedicated to the discussion and resolution of issues related to Classic and Next Generation Amiga hardware. Got a problem with a piece of hardware? Click to speak.

Reply
 
Thread Tools Display Modes
Old 01-14-2006, 04:55 AM   #16
Boot_WB
Defender of the Faith
Points: 11,828, Level: 71 Points: 11,828, Level: 71 Points: 11,828, Level: 71
Activity: 11% Activity: 11% Activity: 11%
 
Boot_WB's Avatar
 
Join Date: Feb 2005
Location: Kingston upon Hull, UK
Posts: 1,236
Default Re: Upgraded BPPC 040 to 060. Just one minor issue...

Tried checkMMU anyway, and it returned nu MMU - methinks probably not set up to handle 06 MMU detection.

Tried also cpu060 and got the following output:

System: 68060LC Mask ? Revision 4
Settings:
(INST: 1/2 Cache Burst)
(DATA: Cache Burst)
(BRANCH: Cache)
(Superscalar)
(WriteBuffer)
(Store/Load Bypass)

Register:
CACR=$A080A000
PCR=$04310403
BUSCR=$00000000

A bit worried about it not detecting the mask number. Any ideas folks?

Furthermore:

SYSinfo crashes when doing a speed test
AIBB crashes when evaluating system.

I have the latest flashrom installed (30/03/99) on the PPC, and am currently using powerup kernel (although same happens with Warpup).

Starting to get worried.... :-?
__________________
www.hullchimneyservices.co.uk

Mac Mini G4 (1.5GHz, 64MB VRam, 1GB Ram): MorphOS 3.1
Powerbook 5.6 (15", 1.67GHz, 128MB VRam, 1GB Ram): MorphOS 3.1, OSX 10.5.8

Windows-free since 2011!
Boot_WB is offline   Reply With Quote
Old 01-14-2006, 05:59 AM   #17
PaSha
Cult Member
Points: 7,222, Level: 56 Points: 7,222, Level: 56 Points: 7,222, Level: 56
Activity: 4% Activity: 4% Activity: 4%
 
Join Date: Oct 2002
Posts: 537
Default Re: Upgraded BPPC 040 to 060. Just one minor issue...

Quote:
Boot_WB wrote:

It seems strange that both chips would be marked EC version, but actually belong to full 060 family. I ahve heard of full 060s marked as ECs, but not LCs marked as ECs.
They are also from different mask sets (75G59Y and Q2G59Y).
Have a look at http://www.czuba-tech.com/CT60/060_mask40.pdf
the G59Y mask is EC/LC only.
Earlier ECs and LCs were made from the same mask as the full 060s (ie F43G), and were full 060s that were either simply relabelled, or had failed some MMU/FPU tests (but most still had more or less working FPUs/MMUs

Quote:
I`d like to be sure the chip is the issue rather than the accelerator before trying to return the CPU for exchange.
If you bought these as full 68060s, then you've been ripped off. In that case, return them and get your money back (or at the very least a full 68060)

-Paul
PaSha is offline   Reply With Quote
Old 01-14-2006, 06:11 AM   #18
Boot_WB
Defender of the Faith
Points: 11,828, Level: 71 Points: 11,828, Level: 71 Points: 11,828, Level: 71
Activity: 11% Activity: 11% Activity: 11%
 
Boot_WB's Avatar
 
Join Date: Feb 2005
Location: Kingston upon Hull, UK
Posts: 1,236
Default Re: Upgraded BPPC 040 to 060. Just one minor issue...

Thanks Paul, that`s just what I needed!!

I was starting to think I`d damaged my BPPC in some bizarre fpu-damaging way.

I`ll look into exchanging my 060 straight away.

Phewww!!! Big sigh of relief!!
__________________
www.hullchimneyservices.co.uk

Mac Mini G4 (1.5GHz, 64MB VRam, 1GB Ram): MorphOS 3.1
Powerbook 5.6 (15", 1.67GHz, 128MB VRam, 1GB Ram): MorphOS 3.1, OSX 10.5.8

Windows-free since 2011!
Boot_WB is offline   Reply With Quote
Old 01-14-2006, 06:27 AM   #19
patrik
Defender of the Faith
Points: 9,201, Level: 64 Points: 9,201, Level: 64 Points: 9,201, Level: 64
Activity: 1% Activity: 1% Activity: 1%
 
Join Date: Apr 2003
Posts: 1,266
Default Re: Upgraded BPPC 040 to 060. Just one minor issue...

@Boot_WB:

Guru Meditation sells full 68060s (both MMU and FPU) to good prices.


/Patrik
patrik is offline   Reply With Quote
Old 01-14-2006, 12:14 PM   #20
Boot_WB
Defender of the Faith
Points: 11,828, Level: 71 Points: 11,828, Level: 71 Points: 11,828, Level: 71
Activity: 11% Activity: 11% Activity: 11%
 
Boot_WB's Avatar
 
Join Date: Feb 2005
Location: Kingston upon Hull, UK
Posts: 1,236
Default Re: Upgraded BPPC 040 to 060. Just one minor issue...

@Piru

Thanks for the info - am certain now that it is the chip, not the board which is at fault.

cpu060 returns PCR value of04310403 (in hex - the first 16 bits in binary translates to 0000010000110001). If it was a board issue there would be no reason for the cpu to return a PCR value stating it is an LC. It should have returned 04300101 (translates to 0000010000110000). I am returning the chip for replacement/refund (hopefully replacement).

:-)
__________________
www.hullchimneyservices.co.uk

Mac Mini G4 (1.5GHz, 64MB VRam, 1GB Ram): MorphOS 3.1
Powerbook 5.6 (15", 1.67GHz, 128MB VRam, 1GB Ram): MorphOS 3.1, OSX 10.5.8

Windows-free since 2011!
Boot_WB is offline   Reply With Quote
Old 01-15-2006, 10:07 AM   #21
Boot_WB
Defender of the Faith
Points: 11,828, Level: 71 Points: 11,828, Level: 71 Points: 11,828, Level: 71
Activity: 11% Activity: 11% Activity: 11%
 
Boot_WB's Avatar
 
Join Date: Feb 2005
Location: Kingston upon Hull, UK
Posts: 1,236
Default Re: Upgraded BPPC 040 to 060. Just one minor issue...

In fairness to this thread & Amigakit.com I must point out that it was myself at fault - I did not read the description of the item properly when buying from Amigakit. It was entitled 68060, but the description stated it was an EC version without FPU.

Despite this Amigakit.com has offered to replace the CPU for a same-priced 50MHz full 060.

You just can't fault them - they are the best!

Am also greatly relieved it was not my soldering at fault :-)
__________________
www.hullchimneyservices.co.uk

Mac Mini G4 (1.5GHz, 64MB VRam, 1GB Ram): MorphOS 3.1
Powerbook 5.6 (15", 1.67GHz, 128MB VRam, 1GB Ram): MorphOS 3.1, OSX 10.5.8

Windows-free since 2011!
Boot_WB is offline   Reply With Quote
Reply

Bookmarks

Tags
upgraded , minor , 040 , 060 , bppc , issue

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
BPPC 603e+ issue *Help Please* Daniele Amiga Hardware Issues and discussion 10 12-09-2008 01:41 PM
Minor BPPC 68040 repairs AJCopland Amiga Hardware Issues and discussion 9 10-25-2007 03:03 AM
Minor crashing issue in 3.9 mschafe Amiga Software Issues and Discussion 8 01-12-2007 06:44 PM
BPPC 040 to 060 upgraded FrankBrana Amiga Hardware Issues and discussion 1 08-13-2006 04:56 AM
Jobberwocky issue -- minor Invisix Amiga Software Issues and Discussion 2 01-22-2004 12:26 PM